Error: NotSupportedError: Failed to load because no supported source was found flutter 1.0.5

I am having the following errors when building my FLUTTER WEB application: hello get this error solved and get this help for the question is :Error: NotSupportedError: Failed to load because no supported source was found flutter

Question Is:

Error: NotSupportedError: Failed to load because no supported source was found.


    at Object.createErrorWithStack (http://localhost:50915/dart_sdk.js:5076:12)
    at Object._rethrow (http://localhost:50915/dart_sdk.js:40477:16)
    at async._AsyncCallbackEntry.new.callback (http://localhost:50915/dart_sdk.js:40473:13)
    at Object._microtaskLoop (http://localhost:50915/dart_sdk.js:40330:13)
    at _startMicrotaskLoop (http://localhost:50915/dart_sdk.js:40336:13)
    at http://localhost:50915/dart_sdk.js:35811:9

The following are my dependencies all in pubspec.yaml:

Error: NotSupportedError: Failed to load because no supported source was found flutter

Failed to load because no supported source was found flutter – Having high rate of flutter, possibly hardware-related; increasing in frequency
Some very cheap laptops that ship with crappy drivers. Nvidia drivers are not very good anymore so you may get weird behaviour. Supports DirectX 9, OpenGL, OpenAL, OpenVG, XInput 1.0 and XInput 1.1Closed source driver, you have to use OpenCL 1.1 with libdrm
Allows you to choose different CPU/GPU Error: NotSupportedError: Failed to load because no supported source was found flutter

Same Error Has been says after Failed to load because no supported source was found:

  cupertino_icons: ^1.0.2
  http: ^0.13.1
  json_annotation: ^4.0.1
  provider: ^5.0.0
  google_fonts: ^2.0.0
  vibration: ^1.7.4-nullsafety.0 #^1.7.4
  firebase_core: ^1.0.2
  cloud_firestore: ^1.0.2
  easy_web_view: ^1.4.0-nullsafety #easy_web_view: ^1.3.0
  intl: ^0.17.0
  uuid: ^3.0.2
  url_launcher: ^6.0.2
  shared_preferences: ^2.0.5

Answer Is:

Change only not open right way proper open file path and get this error find and i am get the finally this error solved and put that all over project assets , images and other files under the assets folder.

Mypath declare on pubspec.yaml in into assets and i am fetch from Note path in main.dart

pubspec.yaml

flutter:

  uses-material-design: true

  assets:
     - assets/song1.wav

main.dart

class _MyPhoneState extends State<MyPhone> {
  void PlaySound(int soundnumber) {
    final player = AudioCache();
    player.play('Note/song$soundnumber.wav');
  }

Leave a Comment